Homekit Italia Group
  • Home

  • Indice del forum!
Link e commenti alle guide e miniguide pubblicate sui gruppi Homekit Italia
 #526  da niccolo
 07/06/2019, 16:17
Ciao a tutti, prima guida postata. Procedura super semplificata (con immagini) per installazione di Homebridge su Mac e conseguente aggiunta delle telecamere IP tramite HomeKit. Come plus, attivazione notifica con invio della snapshot se si ha anche un sensore di movimento HomeKit:

https://www.twibuk.com/upload/files/201 ... 3_file.pdf

Buona lettura! ;)
 #774  da gpl71
 16/07/2019, 17:47
Sciccoso ha scritto: 16/07/2019, 11:53 Sarebbe utile fare un elenco delle ip cam compatibili con home bridge...un consiglio su quale acquistare per non fare un buco nell’acqua.
Magari gli utenti che hanno integrato potrebbero mettere il modello che usano.
Grazie
https://github.com/KhaosT/homebridge-ca ... igurations
 #1040  da MarcoBallarini
 12/08/2019, 14:54
Buongiorno a tutti,
Ho seguito la guida passo passo senza incappare in errori finché non ho modificato il JSON per aggiungere la cam.

{
"bridge": {
"name": "Homebridge",
"username": "CC:30:3E:E3:CC:22",
"pin": "213-12-165"
},
"accessories": [],
"platforms": [{
"platform": "Camera-ffmpeg",
"cameras": [{
"name": "IPCAMERA1",
"videoConfig": {
"source": "-re -f mjpeg -i http://admin:7complus@192.168.2.22/video/mjpg.cgi",
"stillImageSource": "-f mjpeg -i http://admin:7complus@192.168.2.22/image.jpg",
"maxStreams": 2,
"maxWidth": 1280,
"maxHeight": 720,
"maxFPS": 30
}
}]

}]
}

Ho anche validato il JSON e non sembrano esserci errori.
A questo punto homebridge non parte più, qui di seguito gli errori:

MacBook-Pro-di-MB:~ marcoballarini$ homebridge
[12/8/2019, 14:35:45] Loaded config.json with 0 accessories and 1 platforms.
[12/8/2019, 14:35:45] ---
[12/8/2019, 14:35:45] No plugins found. See the README for information on installing plugins.
[12/8/2019, 14:35:45] Loading 1 platforms...
[12/8/2019, 14:35:45] Error: The requested platform 'Camera-ffmpeg' was not registered by any plugin.
at API.platform (/usr/local/lib/node_modules/homebridge/lib/api.js:134:13)
at Server._loadPlatforms (/usr/local/lib/node_modules/homebridge/lib/server.js:327:45)
at Server.run (/usr/local/lib/node_modules/homebridge/lib/server.js:90:36)
at module.exports (/usr/local/lib/node_modules/homebridge/lib/cli.js:59:10)
at Object.<anonymous> (/usr/local/lib/node_modules/homebridge/bin/homebridge:17:22)
at Module._compile (internal/modules/cjs/loader.js:868:30)
at Object.Module._extensions..js (internal/modules/cjs/loader.js:879:10)
at Module.load (internal/modules/cjs/loader.js:731:32)
at Function.Module._load (internal/modules/cjs/loader.js:644:12)
at Function.Module.runMain (internal/modules/cjs/loader.js:931:10)
[12/8/2019, 14:35:45] Got SIGTERM, shutting down Homebridge...

Mi potete aiutare?
 #1049  da gpl71
 13/08/2019, 17:39
La soluzione potrebbe essere questa se stai utilizzando Raspberry :

# install build tools
sudo apt-get install git pkg-config autoconf automake libtool libx264-dev

# download and build fdk-aac
git clone https://github.com/mstorsjo/fdk-aac.git
cd fdk-aac
./autogen.sh
./configure --prefix=/usr/local --enable-shared --enable-static
make -j4
sudo make install
sudo ldconfig
cd ..

# download and build ffmpeg
git clone https://github.com/FFmpeg/FFmpeg.git
cd FFmpeg
./configure --prefix=/usr/local --arch=armel --target-os=linux --enable-omx-rpi --enable-nonfree --enable-gpl --enable-libfdk-aac --enable-mmal --enable-libx264 --enable-decoder=h264 --enable-network --enable-protocol=tcp --enable-demuxer=rtsp
make -j4
sudo make install

Un comando alla volta, e comunque attendi il prompt di raspberry prima di passare al comando successivo... ti occorrerà 30 minuti circa per completare